avatar_Roberto

Evolution Mail findet Drucker nicht

Begonnen von Roberto, 29. November 2020, 12:56:12

⏪ vorheriges - nächstes ⏩

0 Mitglieder und 1 Gast betrachten dieses Thema.

Roberto

Hallo zusammen,

ich habe Artix Gnome openrc installiert und ich muss feststellen, dass es eine echte Alternative zu KDE oder Xfce ist.
Ich möchte auch das standardmäßig installierte Evolution Mail als Mailprogramm nutzen. Ich habe allerdings das Problem, dass Evolution mit mein Drucker nicht klarkommt.
Ich habe einen Epson XP-312, den ich schon lange erfolgreich mit Artix nutze.

Installiert sind folgende Pakete:

epson-inkjet-printer-201301w cups cups-openrc iscan iscan-data iscan-plugin-network

Wenn ich eine Mail drucken möchte, wird mir der Drucker 2x angezeigt. Beim ersten Eintrag können die Informationen über den Drucker nicht geholt werden. Beim zweiten Eintrag kommt eine Verbindung zustande, wenn ich dann auf Drucken klicke, bekomme ich eine Fehlermeldung.

Ich hänge 2 Screenshots an, die das Ganze zusätzlich dokumentieren.

Hat jemand eine Idee woran es liegen könnte?

Mit KMail, Thunderbird oder auch Geary kann ich problemlos drucken.
Nur Evolution Mail macht diese Probleme.

Vielen Dank im Voraus!

Viele Grüße
Roberto
Drum lächle und sei froh, denn es könnte schlimmer kommen. Und ich lächelte und war froh ... und es kam schlimmer ;)

gosia

Hallo Roberto,
verstehe ich das richtig, daß nur Evolution nicht druckt? Da die Fehlermeldung nicht sehr aussagekräftig ist hilft vielleicht ein Blick in /var/log/cups/error_log.
Es ist lange her, daß ich mal Evolution hatte, aber kann man von dort aus nicht auch Druckereinstellungen auswählen, mit den Tabs "Allgemein", "Seite einrichten", "Auftrag", "Druckqualität" und "Erweitert"? Vielleicht auch dort mal nachsehen, speziell unter "Erweitert".
Ist nicht besonders hilfreich, aber irgendwo müssen wir ja anfangen...

viele Grüße gosia

Roberto

Hi avatar_gosia @gosia,

ich habe zwischenzeitlich einen Beitrag im Deutschen Arch Forum gefunden und dort wird gesagt, dass es an der Version 3.38.2 von Evolution liegt.

https://bbs.archlinux.de/viewtopic.php?id=33619

Also wollte ich den empfohlene Downgrade machen und die vorherigen Pakete sind bei mir auch noch in
/var/cache/pacman/pkg
vorhanden.

Trotzdem bekomme ich folgende Fehlermeldung:
Warnung: Kann "libedataserver-1.2.so=24-64" nicht auflösen (eine Abhängigkeit von "evolution")
:: Das folgende Paket kann aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden:
      evolution

Was kann ich machen, damit der Downgrade doch noch funktioniert?

Viele Grüße
Roberto
Drum lächle und sei froh, denn es könnte schlimmer kommen. Und ich lächelte und war froh ... und es kam schlimmer ;)

Daemon

Also braucht Evolution auch ein älteres Paket von libedataserver?

Hast du das auch noch?

Ich habe gerade mal im Arch Archive geschaut, aber nichts gefunden.
I'm worse at what I do best and for this gift I feel blessed

Roberto

Nein, habe ich leider auf meinem System auch nicht gefunden.
Dann werde ich wohl auf ein Update von Evolution warten.

Viele Grüße
Roberto
Drum lächle und sei froh, denn es könnte schlimmer kommen. Und ich lächelte und war froh ... und es kam schlimmer ;)

michi

Hallo,

ist das bei Artix mit dem downgrade nicht wie bei Arch?

$ downgrade evolution-data-server
Available packages:

    1)  evolution-data-server    3.30.4  1  x86_64  (remote)
    2)  evolution-data-server    3.30.5  1  x86_64  (remote)
    3)  evolution-data-server    3.32.0  1  x86_64  (remote)
    4)  evolution-data-server    3.32.0  2  x86_64  (remote)
    5)  evolution-data-server    3.32.1  1  x86_64  (remote)
    6)  evolution-data-server    3.32.2  1  x86_64  (remote)
    7)  evolution-data-server    3.32.3  1  x86_64  (remote)
    8)  evolution-data-server    3.32.4  1  x86_64  (remote)
    9)  evolution-data-server    3.34.0  1  x86_64  (remote)
   10)  evolution-data-server    3.34.1  1  x86_64  (remote)
   11)  evolution-data-server    3.34.1  2  x86_64  (remote)
   12)  evolution-data-server    3.34.2  1  x86_64  (remote)
   13)  evolution-data-server    3.34.3  1  x86_64  (remote)
   14)  evolution-data-server    3.34.4  1  x86_64  (remote)
   15)  evolution-data-server    3.36.0  1  x86_64  (remote)
   16)  evolution-data-server    3.36.1  1  x86_64  (remote)
   17)  evolution-data-server    3.36.2  1  x86_64  (remote)
   18)  evolution-data-server    3.36.2  2  x86_64  (remote)
   19)  evolution-data-server    3.36.3  1  x86_64  (remote)
   20)  evolution-data-server    3.36.3  2  x86_64  (remote)
   21)  evolution-data-server    3.36.4  1  x86_64  (remote)
   22)  evolution-data-server    3.36.5  1  x86_64  (remote)
   23)  evolution-data-server    3.38.0  1  x86_64  (remote)
   24)  evolution-data-server    3.38.1  1  x86_64  (remote)
   25)  evolution-data-server    3.38.2  1  x86_64  (remote)
   26)  evolution-data-server    3.38.2  2  x86_64  (remote)

mfg

Roberto

Ja das ist es und ich habe 2 verschiedene Wege versucht, um Evolution downzugraden.

1.
sudo pacman -U evolution-3.36.5-1-x86_64.pkg.tar.zst

Hier das Ergebnis:
T450S:[roberto]:~$ sudo pacman -U evolution-3.36.5-1-x86_64.pkg.tar.zst
[sudo] Passwort für roberto:
Lade Pakete...
Fehler: 'evolution-3.36.5-1-x86_64.pkg.tar.zst': Konnte Paket nicht finden oder lesen

Die Datei ist aber in /var/chache/pacman/pkg vorhanden.

2.
sudo downgrade evolution
Available packages:

    1)  evolution    3.30.4  1  x86_64  (remote)
    2)  evolution    3.30.5  1  x86_64  (remote)
    3)  evolution    3.32.0  1  x86_64  (remote)
    4)  evolution    3.32.1  1  x86_64  (remote)
    5)  evolution    3.32.2  1  x86_64  (remote)
    6)  evolution    3.32.3  1  x86_64  (remote)
    7)  evolution    3.32.4  1  x86_64  (remote)
    8)  evolution    3.34.0  1  x86_64  (remote)
    9)  evolution    3.34.1  1  x86_64  (remote)
   10)  evolution    3.34.2  1  x86_64  (remote)
   11)  evolution    3.34.3  1  x86_64  (remote)
   12)  evolution    3.34.4  1  x86_64  (remote)
   13)  evolution    3.36.0  1  x86_64  (remote)
   14)  evolution    3.36.1  1  x86_64  (remote)
   15)  evolution    3.36.2  1  x86_64  (remote)
   16)  evolution    3.36.3  1  x86_64  (remote)
   17)  evolution    3.36.4  1  x86_64  (remote)
   18)  evolution    3.36.5  1  x86_64  (remote)
   19)  evolution    3.36.5  1  x86_64  (local)
   20)  evolution    3.38.0  1  x86_64  (remote)
   21)  evolution    3.38.1  1  x86_64  (remote)
+  22)  evolution    3.38.2  1  x86_64  (remote)
+  23)  evolution    3.38.2  1  x86_64  (local)

select a package by number: 19

Ich habe 19) gewählt, weil das die Vorgängerversion ist, die "local" auf meinem Notebook ist und mit der lt. des Threads im Arch Linux Formum funktionieren soll (Ist auch der Beweis zu Punkt 1).

Hier das Ergebnis:
Lade Pakete...
Warnung: Downgrade des Paketes evolution (3.38.2-1 => 3.36.5-1)
Löse Abhängigkeiten auf...
Warnung: Kann "libedataserver-1.2.so=24-64" nicht auflösen (eine Abhängigkeit von "evolution")
:: Das folgende Paket kann aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden:
      evolution

:: Möchten Sie das obengenannte Paket bei dieser Aktualisierung überspringen? [j/N]

Hat beides leider nicht geklappt.

Mehr fällt mir gerade im Moment nicht dazu ein.

Viele Grüße
Roberto
Drum lächle und sei froh, denn es könnte schlimmer kommen. Und ich lächelte und war froh ... und es kam schlimmer ;)